Do I need to upgrade facebookapi_php5_restlib.php (Old PHP Client Lib)?

There is a post in the forum with subject “do I need to upgrade facebookapi_php5_restlib.php ?“.

Basically, the poster has encountered an error in his application that is written based on the Old PHP client lib and seeking for help.

The problem has been identified as a result of calling deprecated API ‘profile.setFBML’.  Although the problem can be solved be removing the API call, but that bring up the question on whether we need to migrate our app from the Old PHP Client Lib to the PHP SDK.

That depends on several factors:

  • whether you keep on enhancing the app
  • the complexity of the app
  • whether it is a FBML canvas app or iframe canvas app

For simple (or not that complex) app that further enhancement is very like to be done in the future, I think it is worth to do the migration.

This entry was posted in Facebook Dev Forum Digest and tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *